---
id: CVE-2026-97254
title: >-
  WordPress Royal Elementor Addons plugin <= 1.7.1069 - Cross Site Scripting
  (XSS) vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in WProyal Royal Elementor Addons
  royal-elementor-addons allows Stored XSS.This issue affects Royal Elementor
  Addons: from n/a through 1.7…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: WProyal
product: royal-elementor-addons
affected:
  - royal-elementor-addons <= 1.7.1069
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-26T10:13:16.358421Z'
published: '2026-10-26'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T10:23:40.688Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-97254'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/royal-elementor-addons/vulnerability/wordpress-royal-elementor-addons-plugin-1-7-1069-cross-site-scripting-xss-vulnerability-2?_s_id=cve
tags:
  - cve.org
ingestedAt: '2026-10-26T10:23:42.836Z'
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WProyal Royal Elementor Addons royal-elementor-addons allows Stored XSS.This issue affects Royal Elementor Addons: from n/a through 1.7.1069.

## Affected

- `royal-elementor-addons <= 1.7.1069`

## Remediation

Update the WordPress Royal Elementor Addons plugin to the latest available version (at least 1.7.1070).
