---
id: CVE-2026-57386
title: WordPress aBlocks plugin < 2.9.1 - Privilege Escalation vulnerability
summary: >-
  Incorrect Privilege Assignment vulnerability in Kodezen LLC aBlocks ablocks
  allows Privilege Escalation.This issue affects aBlocks: from n/a before 2.9.1.
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-266
vendor: Kodezen LLC
product: ablocks
affected:
  - ablocks < 2.9.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-07-13T13:59:06.325207Z'
published: '2026-07-13'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T07:44:40.130Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-57386'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/ablocks/vulnerability/wordpress-ablocks-plugin-2-9-1-privilege-escalation-vulnerability?_s_id=cve
tags:
  - cve.org
epss: 0.00417
epssPercentile: 0.35738
ingestedAt: '2026-10-26T08:21:41.801Z'
---

## Overview

Incorrect Privilege Assignment vulnerability in Kodezen LLC aBlocks ablocks allows Privilege Escalation.This issue affects aBlocks: from n/a before 2.9.1.

## Affected

- `ablocks < 2.9.1`

## Remediation

Update the WordPress aBlocks plugin to the latest available version (at least 2.9.1).
