---
id: CVE-2026-116275
title: >-
  AllenAI AllenNLP Registrable Configuration Machinery registrable.py
  Registrable.resolve_class_name code injection
summary: >-
  A vulnerability was found in AllenAI AllenNLP up to 2.10.1. This impacts the
  function Registrable.resolve_class_name of the file
  allennlp/common/registrable.py of the component Registrable Configuration
  Machinery. Performing a manipulati…
severity: medium
cvss: 6.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L/E:P/RL:X/RC:C'
cvssSource: cna
cwe:
  - CWE-94
  - CWE-74
vendor: AllenAI
product: AllenNLP
affected:
  - AllenNLP 2.10.0
  - AllenNLP 2.10.1
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-26T16:08:05.012456Z'
exploitAvailable: true
published: '2026-10-26'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T16:16:35.290Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116275'
references:
  - url: 'https://vuldb.com/vuln/426304'
    label: >-
      VDB-426304 | AllenAI AllenNLP Registrable Configuration Machinery
      registrable.py Registrable.resolve_class_name code injection
  - url: 'https://vuldb.com/vuln/426304/cti'
    label: 'VDB-426304 | CTI Indicators (IOB, IOC, TTP, IOA)'
  - url: 'https://vuldb.com/cve/CVE-2026-116275'
    label: CVE-2026-116275 | CVE Analysis and Report
  - url: 'https://vuldb.com/submit/1011308'
    label: >-
      Submit #1011308 | AllenAI AllenNLP 2.10.1  Use of Externally-Controlled
      Input to Select Classes or Code
  - url: >-
      https://github.com/3em0/cve_repo/blob/main/2026/AllenNLP_2.10.1_Unsafe_Reflective_Instantiation_RCE_in_FromParams_Configuration_Handling.md
tags:
  - cve.org
  - exploit-available
ingestedAt: '2026-10-26T14:27:31.840Z'
---

## Overview

A vulnerability was found in AllenAI AllenNLP up to 2.10.1. This impacts the function Registrable.resolve_class_name of the file allennlp/common/registrable.py of the component Registrable Configuration Machinery. Performing a manipulation of the argument Type results in code injection. The attack may be initiated remotely. The exploit has been made public and could be used. The vendor was contacted early about this disclosure but did not respond in any way. This vulnerability only affects products that are no longer supported by the maintainer.

## Affected

- `AllenNLP 2.10.0`
- `AllenNLP 2.10.1`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
