---
id: CVE-2026-116184
title: OpenRemote before 1.31.0 Cross-Realm Gateway Impersonation via Websocket
summary: >-
  OpenRemote before 1.31.0 contains an authorization bypass vulnerability that
  allows realm admins to impersonate gateways in other realms because
  GatewayService only checks the gateway ID, not the realm. Attackers with
  WRITE:ADMIN in one …
severity: low
cvss: 2.1
cvssVector: 'CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N'
cvssSource: cna
cwe:
  - CWE-639
vendor: openremote
product: core
affected:
  - core < 1.31.0
published: '2026-10-25'
updated: '2026-10-25'
sourceUpdated: '2026-10-25T13:22:08.792Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116184'
references:
  - url: 'https://github.com/openremote/core/security/advisories/GHSA-2j4x-qh6q-q8mm'
    label: GitHub Security Advisory (GHSA-2j4x-qh6q-q8mm)
  - url: >-
      https://www.vulncheck.com/advisories/openremote-before-1.31.0-cross-realm-gateway-impersonation-via-websocket
    label: >-
      VulnCheck Advisory: OpenRemote before 1.31.0 Cross-Realm Gateway
      Impersonation via Websocket
tags:
  - cve.org
ingestedAt: '2026-10-25T22:08:29.937Z'
---

## Overview

OpenRemote before 1.31.0 contains an authorization bypass vulnerability that allows realm admins to impersonate gateways in other realms because GatewayService only checks the gateway ID, not the realm. Attackers with WRITE:ADMIN in one realm can create a service user named after another realm's gateway ID to overwrite its descendant assets and open SSH tunnels into its local network.

## Affected

- `core < 1.31.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
