---
id: CVE-2026-116176
title: vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector
summary: >-
  vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery
  vulnerability that allows API callers to force outbound connections by
  embedding a decode address in the X-Request-Id header. Attackers can make a
  P2pNcclConnector pref…
severity: high
cvss: 8.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L'
cvssSource: cna
cwe:
  - CWE-918
vendor: vllm-project
product: vllm
affected:
  - vllm >= 0.9.2 < 0.24.0
published: '2026-10-25'
updated: '2026-10-25'
sourceUpdated: '2026-10-25T13:20:16.476Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116176'
references:
  - url: >-
      https://github.com/vllm-project/vllm/security/advisories/GHSA-vfp2-c8pq-v6h6
    label: GitHub Security Advisory (GHSA-vfp2-c8pq-v6h6)
  - url: >-
      https://www.vulncheck.com/advisories/vllm-0.9.2-before-0.24.0-ssrf-via-x-request-id-in-p2pncclconnector
    label: >-
      VulnCheck Advisory: vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in
      P2pNcclConnector
tags:
  - cve.org
ingestedAt: '2026-10-25T22:08:29.946Z'
---

## Overview

vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the X-Request-Id header. Attackers can make a P2pNcclConnector prefill worker ZMQ-connect to an attacker host, leaking the NCCL unique_id and KV-cache tensors or blocking the worker.

## Affected

- `vllm >= 0.9.2 < 0.24.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
