---
id: CVE-2026-116174
title: vLLM 0.22.0 before 0.24.0 Denial of Service via Rust gRPC Generate
summary: >-
  vLLM from 0.22.0 before 0.24.0 contains an improper input validation
  vulnerability in the Rust gRPC Generate and GenerateStream service that
  forwards unchecked prompt token IDs to EngineCore. Attackers can submit
  requests with out-of-voc…
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-20
vendor: vllm-project
product: vllm
affected:
  - vllm >= 0.22.0 < 0.24.0
published: '2026-10-25'
updated: '2026-10-25'
sourceUpdated: '2026-10-25T13:20:15.109Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116174'
references:
  - url: >-
      https://github.com/vllm-project/vllm/security/advisories/GHSA-w2v2-5662-8v5q
    label: GitHub Security Advisory (GHSA-w2v2-5662-8v5q)
  - url: >-
      https://www.vulncheck.com/advisories/vllm-0.22.0-before-0.24.0-denial-of-service-via-rust-grpc-generate
    label: >-
      VulnCheck Advisory: vLLM 0.22.0 before 0.24.0 Denial of Service via Rust
      gRPC Generate
tags:
  - cve.org
ingestedAt: '2026-10-25T22:08:29.947Z'
---

## Overview

vLLM from 0.22.0 before 0.24.0 contains an improper input validation vulnerability in the Rust gRPC Generate and GenerateStream service that forwards unchecked prompt token IDs to EngineCore. Attackers can submit requests with out-of-vocabulary prompt.token_ids values to trigger a fatal embedding lookup failure that terminates EngineCore and leaves the server unhealthy.

## Affected

- `vllm >= 0.22.0 < 0.24.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
