---
id: CVE-2026-116172
title: vLLM 0.22.0 before 0.24.0 DoS via Rust gRPC CandidateTokens.top_n
summary: >-
  vLLM from 0.22.0 before 0.24.0 contains an improper input validation
  vulnerability in the Rust gRPC converter that allows remote attackers to
  bypass max_logprobs limits via CandidateTokens.top_n. Attackers can send
  Generate or GenerateSt…
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-20
vendor: vllm-project
product: vllm
affected:
  - vllm >= 0.22.0 < 0.24.0
published: '2026-10-25'
updated: '2026-10-25'
sourceUpdated: '2026-10-25T13:20:13.759Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116172'
references:
  - url: >-
      https://github.com/vllm-project/vllm/security/advisories/GHSA-rwfw-xvg3-3937
    label: GitHub Security Advisory (GHSA-rwfw-xvg3-3937)
  - url: >-
      https://www.vulncheck.com/advisories/vllm-0.22.0-before-0.24.0-dos-via-rust-grpc-candidatetokens-top-n
    label: >-
      VulnCheck Advisory: vLLM 0.22.0 before 0.24.0 DoS via Rust gRPC
      CandidateTokens.top_n
tags:
  - cve.org
ingestedAt: '2026-10-25T22:08:29.948Z'
---

## Overview

vLLM from 0.22.0 before 0.24.0 contains an improper input validation vulnerability in the Rust gRPC converter that allows remote attackers to bypass max_logprobs limits via CandidateTokens.top_n. Attackers can send Generate or GenerateStream requests with oversized or integer-wrapping top_n values to trigger torch.topk failures that terminate EngineCore.

## Affected

- `vllm >= 0.22.0 < 0.24.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
