---
id: CVE-2026-116148
title: >-
  ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 Code Injection via MVG
  Encoder Drawing Options
summary: >-
  ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains an injection
  vulnerability in the MVG encoder, which does not properly neutralize
  user-specified drawing options before writing them into generated MVG output.
  Attackers who c…
severity: low
cvss: 3.6
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: ImageMagick
product: ImageMagick
affected:
  - ImageMagick >= 7.0.0-0 < 7.1.2-33
  - ImageMagick < 6.9.13-58
published: '2026-10-25'
updated: '2026-10-25'
sourceUpdated: '2026-10-25T13:19:57.729Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116148'
references:
  - url: >-
      https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-qq8x-fq3x-43h4
    label: GitHub Security Advisory (GHSA-qq8x-fq3x-43h4)
  - url: >-
      https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-33-code-injection-via-mvg-encoder-drawing-options
    label: >-
      VulnCheck Advisory: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33
      Code Injection via MVG Encoder Drawing Options
tags:
  - cve.org
ingestedAt: '2026-10-25T22:08:29.953Z'
---

## Overview

ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains an injection vulnerability in the MVG encoder, which does not properly neutralize user-specified drawing options before writing them into generated MVG output. Attackers who can supply drawing options can inject arbitrary MVG drawing commands into the resulting MVG file.

## Affected

- `ImageMagick >= 7.0.0-0 < 7.1.2-33`
- `ImageMagick < 6.9.13-58`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
