---
id: CVE-2026-116145
title: >-
  ImageMagick before 6.9.13-58 and 7.x before 7.1.2-32 Security Policy Bypass
  via Incomplete Fix
summary: >-
  ImageMagick before 6.9.13-58 and 7.x before 7.1.2-32 contains a security
  policy bypass caused by an incomplete fix for the policy bypass reported in
  GHSA-jjp4-3fwf-393j. An attacker able to supply input to ImageMagick can evade
  configure…
severity: low
cvss: 3.9
cvssVector: 'CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-693
vendor: ImageMagick
product: ImageMagick
affected:
  - ImageMagick >= 7.0.0-0 < 7.1.2-32
  - ImageMagick < 6.9.13-58
published: '2026-10-25'
updated: '2026-10-25'
sourceUpdated: '2026-10-25T13:19:55.780Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116145'
references:
  - url: >-
      https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-4wfv-467j-fqh9
    label: GitHub Security Advisory (GHSA-4wfv-467j-fqh9)
  - url: >-
      https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-32-security-policy-bypass-via-incomplete-fix
    label: >-
      VulnCheck Advisory: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-32
      Security Policy Bypass via Incomplete Fix
tags:
  - cve.org
ingestedAt: '2026-10-25T22:08:29.954Z'
---

## Overview

ImageMagick before 6.9.13-58 and 7.x before 7.1.2-32 contains a security policy bypass caused by an incomplete fix for the policy bypass reported in GHSA-jjp4-3fwf-393j. An attacker able to supply input to ImageMagick can evade configured security policy restrictions, allowing operations the policy was intended to block.

## Affected

- `ImageMagick >= 7.0.0-0 < 7.1.2-32`
- `ImageMagick < 6.9.13-58`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
