---
id: CVE-2026-116144
title: >-
  ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 Stack Overflow via MVG
  Decoder
summary: >-
  ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains uncontrolled
  recursion in the MVG decoder that can lead to a stack overflow. Attackers can
  supply a crafted MVG file that, when read with specific arguments, exhausts
  the stac…
severity: low
cvss: 3.3
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L'
cvssSource: cna
cwe:
  - CWE-674
vendor: ImageMagick
product: ImageMagick
affected:
  - ImageMagick >= 7.0.0-0 < 7.1.2-33
  - ImageMagick < 6.9.13-58
published: '2026-10-25'
updated: '2026-10-25'
sourceUpdated: '2026-10-25T13:19:55.066Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116144'
references:
  - url: >-
      https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-x258-xjqf-6j3f
    label: GitHub Security Advisory (GHSA-x258-xjqf-6j3f)
  - url: >-
      https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-33-stack-overflow-via-mvg-decoder
    label: >-
      VulnCheck Advisory: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33
      Stack Overflow via MVG Decoder
tags:
  - cve.org
ingestedAt: '2026-10-25T22:08:29.954Z'
---

## Overview

ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains uncontrolled recursion in the MVG decoder that can lead to a stack overflow. Attackers can supply a crafted MVG file that, when read with specific arguments, exhausts the stack and crashes the process, causing a denial of service.

## Affected

- `ImageMagick >= 7.0.0-0 < 7.1.2-33`
- `ImageMagick < 6.9.13-58`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
