---
id: CVE-2026-116143
title: >-
  ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 Policy Bypass in PS, PDF
  and XPS Decoders
summary: >-
  ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a policy bypass
  in the PS, PDF and XPS decoders that allows the security policy's list length
  limit on scene selection to be circumvented. Attackers supplying a specific
  argum…
severity: low
cvss: 3.3
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L'
cvssSource: cna
cwe:
  - CWE-770
vendor: ImageMagick
product: ImageMagick
affected:
  - ImageMagick >= 7.0.0-0 < 7.1.2-33
  - ImageMagick < 6.9.13-58
published: '2026-10-25'
updated: '2026-10-25'
sourceUpdated: '2026-10-25T13:19:54.384Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116143'
references:
  - url: >-
      https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-fp46-842c-2v83
    label: GitHub Security Advisory (GHSA-fp46-842c-2v83)
  - url: >-
      https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-33-policy-bypass-in-ps-pdf-and-xps-decoders
    label: >-
      VulnCheck Advisory: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33
      Policy Bypass in PS, PDF and XPS Decoders
tags:
  - cve.org
ingestedAt: '2026-10-25T22:08:29.955Z'
---

## Overview

ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a policy bypass in the PS, PDF and XPS decoders that allows the security policy's list length limit on scene selection to be circumvented. Attackers supplying a specific argument can cause ImageMagick to process more scenes than permitted, potentially exhausting resources.

## Affected

- `ImageMagick >= 7.0.0-0 < 7.1.2-33`
- `ImageMagick < 6.9.13-58`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
