---
id: CVE-2026-116142
title: ImageMagick before 7.1.2-33 Heap Buffer Over-Read via Minimum-Bounding-Box
summary: >-
  ImageMagick before 7.1.2-33 contains a heap buffer over-read vulnerability
  that allows attackers to read beyond allocated memory when printing a
  minimum-bounding-box. Attackers can supply a crafted image that triggers the
  over-read durin…
severity: low
cvss: 3.3
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-125
vendor: ImageMagick
product: ImageMagick
affected:
  - ImageMagick < 7.1.2-33
published: '2026-10-25'
updated: '2026-10-25'
sourceUpdated: '2026-10-25T13:19:53.714Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116142'
references:
  - url: >-
      https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-5222-mhv9-26rg
    label: GitHub Security Advisory (GHSA-5222-mhv9-26rg)
  - url: >-
      https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-33-heap-buffer-over-read-via-minimum-bounding-box
    label: >-
      VulnCheck Advisory: ImageMagick before 7.1.2-33 Heap Buffer Over-Read via
      Minimum-Bounding-Box
tags:
  - cve.org
ingestedAt: '2026-10-25T22:08:29.955Z'
---

## Overview

ImageMagick before 7.1.2-33 contains a heap buffer over-read vulnerability that allows attackers to read beyond allocated memory when printing a minimum-bounding-box. Attackers can supply a crafted image that triggers the over-read during minimum-bounding-box output, causing crashes or exposing adjacent heap memory.

## Affected

- `ImageMagick < 7.1.2-33`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
