---
id: CVE-2026-116123
title: NocoDB signup validatePassword excessive authentication
summary: >-
  A weakness has been identified in NocoDB up to 2026.07.0. The affected element
  is the function validatePassword of the file /auth/user/signup. Executing a
  manipulation can lead to improper restriction of excessive authentication
  attempts…
severity: low
cvss: 3.7
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N/E:X/RL:X/RC:C'
cvssSource: cna
cwe:
  - CWE-307
  - CWE-799
product: NocoDB
affected:
  - NocoDB 2026.07
published: '2026-10-26'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T05:45:14.291Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116123'
references:
  - url: 'https://vuldb.com/vuln/426191'
    label: VDB-426191 | NocoDB signup validatePassword excessive authentication
  - url: 'https://vuldb.com/vuln/426191/cti'
    label: 'VDB-426191 | CTI Indicators (IOB, IOC, TTP, IOA)'
  - url: 'https://vuldb.com/cve/CVE-2026-116123'
    label: CVE-2026-116123 | CVE Analysis and Report
  - url: 'https://vuldb.com/submit/1004902'
    label: >-
      Submit #1004902 | nocodb <= 2026.07.0 Improper Restriction of Excessive
      Authentication Attempts
  - url: 'https://github.com/nocodb/nocodb/issues/14688'
  - url: 'https://github.com/nocodb/nocodb/'
tags:
  - cve.org
ingestedAt: '2026-10-26T06:19:06.926Z'
---

## Overview

A weakness has been identified in NocoDB up to 2026.07.0. The affected element is the function validatePassword of the file /auth/user/signup. Executing a manipulation can lead to improper restriction of excessive authentication attempts. It is possible to launch the attack remotely. This attack is characterized by high complexity. The exploitability is described as difficult. The vendor documents this as intentional. The vendor deleted the GitHub issue for this vulnerability without any explanation. Afterwards the vendor was contacted early about this disclosure via email but did not respond in any way.

## Affected

- `NocoDB 2026.07`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
