---
id: CVE-2026-116107
title: >-
  Datafeedr Product Sets Plugin AJAX Handlers ajax.php
  dfrps_ajax_delete_saved_search authorization
summary: >-
  A vulnerability was detected in Datafeedr Product Sets Plugin up to 1.3.24 on
  WordPress. Affected by this issue is the function
  dfrps_ajax_delete_saved_search of the file functions/ajax.php of the component
  AJAX Handlers. The manipulatio…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L/E:P/RL:O/RC:C'
cvssSource: cna
cwe:
  - CWE-862
  - CWE-863
vendor: Datafeedr
product: Product Sets Plugin
affected:
  - product_sets_plugin 1.3.0
  - product_sets_plugin 1.3.1
  - product_sets_plugin 1.3.2
  - product_sets_plugin 1.3.3
  - product_sets_plugin 1.3.4
  - product_sets_plugin 1.3.5
  - product_sets_plugin 1.3.6
  - product_sets_plugin 1.3.7
  - product_sets_plugin 1.3.8
  - product_sets_plugin 1.3.9
  - product_sets_plugin 1.3.10
  - product_sets_plugin 1.3.11
  - product_sets_plugin 1.3.12
  - product_sets_plugin 1.3.13
  - product_sets_plugin 1.3.14
  - product_sets_plugin 1.3.15
  - product_sets_plugin 1.3.16
  - product_sets_plugin 1.3.17
  - product_sets_plugin 1.3.18
  - product_sets_plugin 1.3.19
  - product_sets_plugin 1.3.20
  - product_sets_plugin 1.3.21
  - product_sets_plugin 1.3.22
  - product_sets_plugin 1.3.23
  - product_sets_plugin 1.3.24
published: '2026-10-26'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T01:45:13.113Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116107'
references:
  - url: 'https://vuldb.com/vuln/426175'
    label: >-
      VDB-426175 | Datafeedr Product Sets Plugin AJAX Handlers ajax.php
      dfrps_ajax_delete_saved_search authorization
  - url: 'https://vuldb.com/vuln/426175/cti'
    label: 'VDB-426175 | CTI Indicators (IOB, IOC, IOA)'
  - url: 'https://vuldb.com/cve/CVE-2026-116107'
    label: CVE-2026-116107 | CVE Analysis and Report
  - url: 'https://vuldb.com/submit/1002663'
    label: >-
      Submit #1002663 | Datafeedr Datafeedr Product Sets 1.3.24 Missing
      Authorization
  - url: 'https://wordpress.org/plugins/datafeedr-product-sets/'
tags:
  - cve.org
ingestedAt: '2026-10-26T02:13:26.477Z'
---

## Overview

A vulnerability was detected in Datafeedr Product Sets Plugin up to 1.3.24 on WordPress. Affected by this issue is the function dfrps_ajax_delete_saved_search of the file functions/ajax.php of the component AJAX Handlers. The manipulation results in missing authorization. The attack may be launched remotely. The exploit is now public and may be used. Upgrading to version 1.3.25 can resolve this issue. Upgrading the affected component is advised. The vendor was contacted early about this disclosure.

## Affected

- `product_sets_plugin 1.3.0`
- `product_sets_plugin 1.3.1`
- `product_sets_plugin 1.3.2`
- `product_sets_plugin 1.3.3`
- `product_sets_plugin 1.3.4`
- `product_sets_plugin 1.3.5`
- `product_sets_plugin 1.3.6`
- `product_sets_plugin 1.3.7`
- `product_sets_plugin 1.3.8`
- `product_sets_plugin 1.3.9`
- `product_sets_plugin 1.3.10`
- `product_sets_plugin 1.3.11`
- `product_sets_plugin 1.3.12`
- `product_sets_plugin 1.3.13`
- `product_sets_plugin 1.3.14`
- `product_sets_plugin 1.3.15`
- `product_sets_plugin 1.3.16`
- `product_sets_plugin 1.3.17`
- `product_sets_plugin 1.3.18`
- `product_sets_plugin 1.3.19`
- `product_sets_plugin 1.3.20`
- `product_sets_plugin 1.3.21`
- `product_sets_plugin 1.3.22`
- `product_sets_plugin 1.3.23`
- `product_sets_plugin 1.3.24`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
