---
id: CVE-2026-115950
title: >-
  WordPress Better Post & Filter Widgets for Elementor plugin <= 1.9.1 - Cross
  Site Scripting (XSS) vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in WP Smart Widgets Better Post & Filter Widgets for
  Elementor better-post-filter-widgets-for-elementor allows Stored XSS.This
  issue affec…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: WP Smart Widgets
product: better-post-filter-widgets-for-elementor
affected:
  - better-post-filter-widgets-for-elementor <= 1.9.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-26T12:46:15.700640Z'
published: '2026-10-26'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T12:54:34.713Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-115950'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/better-post-filter-widgets-for-elementor/vulnerability/wordpress-better-post-filter-widgets-for-elementor-plugin-1-9-1-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
ingestedAt: '2026-10-26T11:24:53.916Z'
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Smart Widgets Better Post & Filter Widgets for Elementor better-post-filter-widgets-for-elementor allows Stored XSS.This issue affects Better Post & Filter Widgets for Elementor: from n/a through 1.9.1.

## Affected

- `better-post-filter-widgets-for-elementor <= 1.9.1`

## Remediation

Update the WordPress Better Post & Filter Widgets for Elementor plugin to the latest available version (at least 1.9.2).
