---
id: CVE-2026-115948
title: WordPress Media LIbrary Assistant plugin <= 3.42 - SQL Injection vulnerability
summary: >-
  Improper Neutralization of Special Elements used in an SQL Command ('SQL
  Injection') vulnerability in David Lingren Media LIbrary Assistant
  media-library-assistant allows Blind SQL Injection.This issue affects Media
  LIbrary Assistant: fr…
severity: high
cvss: 8.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:L'
cvssSource: cna
cwe:
  - CWE-89
vendor: David Lingren
product: media-library-assistant
affected:
  - media-library-assistant <= 3.42
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-26T12:46:27.420670Z'
published: '2026-10-26'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T12:54:35.005Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-115948'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/media-library-assistant/vulnerability/wordpress-media-library-assistant-plugin-3-42-sql-injection-vulnerability?_s_id=cve
tags:
  - cve.org
ingestedAt: '2026-10-26T11:24:53.923Z'
---

## Overview

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in David Lingren Media LIbrary Assistant media-library-assistant allows Blind SQL Injection.This issue affects Media LIbrary Assistant: from n/a through 3.42.

## Affected

- `media-library-assistant <= 3.42`

## Remediation

Update the WordPress Media LIbrary Assistant plugin to the latest available version (at least 3.43).
