---
id: CVE-2026-115192
title: >-
  An SQL Injection vulnerability exists in the dashboard widget data API
  endpoint (/api/data/{type})
summary: >-
  An SQL Injection vulnerability exists in the dashboard widget data API
  endpoint (/api/data/{type}). Chart filter parameters supplied by the client
  are not properly validated before they are used in the database queries that
  build dashboa…
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L'
cvssSource: cna
cwe:
  - CWE-89
product: mautic/core
affected:
  - mautic/core >= 2.8.1 < 5.2.12
  - mautic/core >= 6.0.0 < 6.0.10
  - mautic/core >= 7.0.0 < 7.2.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-26T14:58:34.553576Z'
published: '2026-10-26'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T15:35:53.230Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-115192'
references:
  - url: 'https://github.com/mautic/mautic/security/advisories/GHSA-qpmx-7pq3-5q2v'
tags:
  - cve.org
ingestedAt: '2026-10-26T14:27:31.839Z'
---

## Overview

An SQL Injection vulnerability exists in the dashboard widget data API endpoint (/api/data/{type}). Chart filter parameters supplied by the client are not properly validated before they are used in the database queries that build dashboard chart data. An authenticated user with API access can exploit this to inject SQL into these reporting queries. Using blind SQL injection techniques, the attacker can read arbitrary data from the Mautic database, including contact and other marketing data and user account data with password hashes. The injected SQL can also be used to slow down database queries, which can have a limited impact on availability. Data modification is not possible through this vulnerability. Exploitation requires the Mautic API to be enabled.

## Affected

- `mautic/core >= 2.8.1 < 5.2.12`
- `mautic/core >= 6.0.0 < 6.0.10`
- `mautic/core >= 7.0.0 < 7.2.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

### Workarounds

There are no official workarounds. To mitigate this vulnerability without upgrading, disable the Mautic API if it is not needed, or restrict API access to trusted users only.
